Search found 117 matches

by Janak Mulani
15 Jun 2021, 12:51
Forum: Public Forums
Topic: Security settings partially greyed out
Replies: 2
Views: 20

Re: Security settings partially greyed out

Hi Jeroen, Can you please tell us the exact steps to reproduce this? I.e you installed, started itw-settings and found that security options are greyed? Have by any chance locked those properties? https://openwebstart.com/docs/OWSGuide.html#_locking_a_property Can you check if in your deployment.pro...
by Janak Mulani
14 Jun 2021, 13:13
Forum: Public Forums
Topic: TimeoutException
Replies: 2
Views: 21

Re: TimeoutException

Hi, Which version of OWS are you using? Can you please provide us the log files? Do you face this issue always? Can you please describe the steps to reproduce the issue ? From the Exception Stack Trace all I can say is that OWS is trying to create a Process to query the Windows Registry on your mach...
by Janak Mulani
27 May 2021, 08:22
Forum: Public Forums
Topic: Image Reader iterator is empty in macOS
Replies: 5
Views: 168

Re: Image Reader iterator is empty in macOS

image file is getting download How have you specified the image file that is used by your app? Normally you would put all resources in a jar file and specify the jar file under resources tag in your jnlp file. OWS downloads and caches all resources (jars) in User Home/.cache/icedtea-web/cache direc...
by Janak Mulani
25 May 2021, 19:20
Forum: Public Forums
Topic: [SOLVED] Executing OpenWebStart from the terminal in MacOS
Replies: 1
Views: 88

Re: Executing OpenWebStart from the terminal in MacOS

When you install OWS on Mac let's say it got Installed in the OpenWebStart folder under Applications. (You can find it through the Finder). On the OpenWebStart folder on the context menu choose Services > New Terminal at Folder. This opens the Terminal at OpenWebStart directory. Suppose you have dow...
by Janak Mulani
25 May 2021, 18:10
Forum: Public Forums
Topic: Image Reader iterator is empty in macOS
Replies: 5
Views: 168

Re: Image Reader iterator is empty in macOS

Which version of OWS are you using? Which version of Java is being used to run the app on Windows and Mac? Do you mean to say that the a version of OWS on Windows is able to start your jnlp app but the same version of OWS on Mac is not able to start the same jnlp app? Is there any exception in the l...
by Janak Mulani
19 May 2021, 17:25
Forum: Installation & Configuration
Topic: Oracle Webforms? Will this work?
Replies: 7
Views: 385

Re: Oracle Webforms? Will this work?

Hi

You can attach the log as .txt to a post. Also if possible attach your jnlp file as a .txt file.

Which JVM and version are you using to start your app?

Thanks

Janak
by Janak Mulani
19 May 2021, 15:32
Forum: Installation & Configuration
Topic: [SOLVED] Unsigned Jar issue with older IPMI jnlp viewer
Replies: 8
Views: 1285

Re: [SOLVED] Unsigned Jar issue with older IPMI jnlp viewer

Hi Just to clarify: You said that the same jnlp worked with OWS 1.2.2 but is not working with OWS v 1.3.3. It used to work with v 1.2.2 after you made changes regarding MD5 to java.security of the azul_11.0.7 JVM used to run the jnlp app. When you run with OWS 1.3.3 you use the Adopt jdk1.8.0_92 JVM...
by Janak Mulani
14 May 2021, 10:19
Forum: Installation & Configuration
Topic: [SOLVED] Unsigned Jar issue with older IPMI jnlp viewer
Replies: 8
Views: 1285

Re: [SOLVED] Unsigned Jar issue with older IPMI jnlp viewer

Hi Dimitri, Thanks for posting the solution to your issue. However it is not clear if you are still facing with OWS 1.3.3 the issue: Initialization Error: Could not initialize application. (Fatal: Application Error: Cannot grant permissions to unsigned jars. Application requested security permission...
by Janak Mulani
20 Apr 2021, 18:29
Forum: Public Forums
Topic: Slow startup?
Replies: 5
Views: 589

Re: Slow startup?

Hi,

I would like to know if you have specified deployment.system.security.policy property in your deployment.config file. If yes can you please share your deployment.config file?

Thanks

Janak
by Janak Mulani
18 Apr 2021, 09:23
Forum: Installation & Configuration
Topic: Oracle Webforms? Will this work?
Replies: 7
Views: 385

Re: Oracle Webforms? Will this work?

Which version of OWS are you using?

Can you please enable logging and send us the logs?

Thanks
by Janak Mulani
18 Mar 2021, 13:53
Forum: Installation & Configuration
Topic: [SOLVED] jnlp vendor selection
Replies: 2
Views: 298

Re: jnlp vendor selection

The preferred jvm vendor has to be specified as follows in the jnlp file:

Code: Select all

<resources>
        <java version="1.8+" vendor="adopt"/>
by Janak Mulani
11 Mar 2021, 16:12
Forum: Public Forums
Topic: [SOLVED] Protoclol_version Error launching from TLS 1.3 server
Replies: 6
Views: 621

Re: [SOLVED] Protoclol_version Error launching from TLS 1.3 server

Hi Richard, I cannot say why it is not working for you. However I tried the TLS1.3 sample given here https://blog.gypsyengineer.com/en/security/an-example-of-tls-13-client-and-server-on-java.html . This sample does not work with AO JRE 8 u 265 (the bundled JRE of OWS) but it works with AO JRE 8 u 27...
by Janak Mulani
11 Mar 2021, 13:23
Forum: Public Forums
Topic: [SOLVED] Protoclol_version Error launching from TLS 1.3 server
Replies: 6
Views: 621

Re: [SOLVED] Protoclol_version Error launching from TLS 1.3 server

Hi I am not sure what steps you followed. I hope here is what you did: 1. Install OWS 2. Go to <OWS install dir>/jre 3. you can rename this to jre_8_u265 4. Install a JVM 8 u 272 or later on your machine 5. Copy JRE directory from that JVM to OWS install dir. 6. From command line >javaws <url of jnl...
by Janak Mulani
11 Mar 2021, 10:39
Forum: Public Forums
Topic: [SOLVED] Protoclol_version Error launching from TLS 1.3 server
Replies: 6
Views: 621

Re: [SOLVED] Protoclol_version Error launching from TLS 1.3 server

As part of OWS installation there is a JRE directory under the installation directory. This JRE is used to start OWS and download the jnlp file. The current version is 8 u 265. You could replace this JRE with 8 u 272+. Can you please try this and report back if it solved your issue?

Thanks
by Janak Mulani
12 Feb 2021, 07:43
Forum: Public Forums
Topic: Running web jnlp on Ubuntu 18.04 LTS 64 - Can't load library:ibglassgtk3.so
Replies: 9
Views: 929

Re: Running web jnlp on Ubuntu 18.04 LTS 64 - Can't load library:ibglassgtk3.so

Hi javac is irrelevant. For running an app specified in a jnlp file you need to specify in the jnlp which JRE you want to use run the app. OWS then looks for that JRE on your machine or tries to download it. You can specify using the itw-settings tool how OWS manages the JVM used to run the app. Ple...
by Janak Mulani
11 Feb 2021, 15:57
Forum: Public Forums
Topic: [SOLVED] Is it possible to use a single jar file to start as an applet and as an application?
Replies: 7
Views: 749

Re: Is it possible to use a single jar file to start as an applet and as an application?

Hi, Are you using the same Java class that you have attached in a post above? This class leads to StackOverflow as the logMsg method is called recursively. I had a look at your class. In my opinion you need to clean up its code. Here is my implementation of the class that will run both in applet mod...
by Janak Mulani
10 Feb 2021, 08:10
Forum: Public Forums
Topic: [SOLVED] Is it possible to use a single jar file to start as an applet and as an application?
Replies: 7
Views: 749

Re: Is it possible to use a single jar file to start as an applet and as an application?

Hi In the JNLP file for running as an application you still have: <applet-desc name="HelloWorldGuiApplet" main-class="HelloWorldGuiApplet" width="1024" height="768"> <argument>Hello world!!!!</argument> </applet-desc> Is this a copy+paste error? Changing it to application-desc should work. Btw, what...
by Janak Mulani
11 Jan 2021, 10:40
Forum: Public Forums
Topic: launching from web url, onn x32 linux
Replies: 12
Views: 1438

Re: launching from web url, onn x32 linux

Just for information the app works with Java 11 on Windows 64.

Code: Select all

javaws https://boardspace.net/java/boardspace7.jnlp
Just to confirm you are using 32 bit linux and JVM is 32 bit azul_11.0.7, is this correct?

Thanks

Janak
by Janak Mulani
11 Jan 2021, 06:03
Forum: Public Forums
Topic: [SOLVED] Thawte code signing issuer CA missing
Replies: 4
Views: 680

Re: Thawte code signing issuer CA missing

>
After downloading the "CN=thawte SHA256 Code Signing CA - G2" from Thawte and imported it, it works.
>

Just for information, in which JVM's certificate store did you import the above certificate, OWS's bundled JVM or the JVM that you use to run the app?

Thanks