Search found 137 matches

by Stephan Classen
17 May 2021, 16:32
Forum: Installation & Configuration
Topic: jnlp File with a lot of Jar's
Replies: 1
Views: 3

Re: jnlp File with a lot of Jar's

Having too many extensions can cause problems, especially if some of these extensions only contain other extensions and no resources (e.g. jar files). So from a risk reducing point of view go with a single JNLP. If this on the other hand ends up in an unmanageable JNLP then create a few extensions. ...
by Stephan Classen
17 May 2021, 16:29
Forum: Installation & Configuration
Topic: [SOLVED] Unsigned Jar issue with older IPMI jnlp viewer
Replies: 4
Views: 696

Re: [SOLVED] Unsigned Jar issue with older IPMI jnlp viewer

The console log you included contains the following line: Exception while downloading resource location=https://172.29.20.47:9443//gsmr/resources/lib/subm-simcard-webstart.jar version=null state=INCOMPLETE from https://172.29.20.47:9443//gsmr/resources/lib/subm-simcard-webstart.jar - Connection refu...
by Stephan Classen
22 Apr 2021, 12:24
Forum: Public Forums
Topic: Multi-Release Jars seem not to be working
Replies: 9
Views: 1564

Re: Multi-Release Jars seem not to be working

A fix for the multi release problem was added to the version 1.4.0:
https://github.com/AdoptOpenJDK/IcedTea-Web/pull/797
by Stephan Classen
22 Apr 2021, 10:42
Forum: Installation & Configuration
Topic: [SOLVED] Allow user to accept JNLP security requests?
Replies: 4
Views: 244

Re: Allow user to accept JNLP security requests?

Yes, your interpretation is correct.
I had to look it up myself as I haven't stumbled over this feature of ITW yet. :)
by Stephan Classen
01 Apr 2021, 10:55
Forum: Installation & Configuration
Topic: [SOLVED] Support for deployment.security.level?
Replies: 1
Views: 132

Re: Support for deployment.security.level?

Yes, we did not have time to document all the flags and features.

The default for deployment.security.level is ASK_UNSIGNED which is equivalent to HIGH in the oracle settings.
by Stephan Classen
01 Apr 2021, 10:50
Forum: Installation & Configuration
Topic: [SOLVED] Documentation bug
Replies: 1
Views: 110

Re: [SOLVED] Documentation bug

Thank you for reporting this. We have fixed the documentation.
by Stephan Classen
01 Apr 2021, 10:45
Forum: Installation & Configuration
Topic: [SOLVED] Allow user to accept JNLP security requests?
Replies: 4
Views: 244

Re: Allow user to accept JNLP security requests?

Sorry, so far we did not find the time to document all features and flags which are available in ITW and OWS.
If you need to know more details about anything please feel free to ask
by Stephan Classen
30 Mar 2021, 10:35
Forum: Public Forums
Topic: [SOLVED] How to set the Log Console = Show, using configuration property
Replies: 2
Views: 138

Re: How to set the Log Console = Show, using configuration property

deployment.console.startup.mode=SHOW

You need to put the above line into the file "deployment.properties" in the folder "%user_home%\.config\icedtea-web"
by Stephan Classen
18 Mar 2021, 09:59
Forum: Installation & Configuration
Topic: [SOLVED] On re-installation, Settings are not changing to default
Replies: 2
Views: 185

Re: On re-installation, Settings are not changing to default

Hi Amitabha

Yes this is the expected behavior.
If you want to reset your config to default you need to delete the deployment.properties file.
This file is located in your users home dir below ".config/icedtea-web"
by Stephan Classen
10 Mar 2021, 19:40
Forum: Public Forums
Topic: [SOLVED] Protoclol_version Error launching from TLS 1.3 server
Replies: 6
Views: 421

Re: Protoclol_version Error launching from TLS 1.3 server

According to https://github.com/AdoptOpenJDK/openjdk ... ssues/1254 TLS 1.3 support was added in 8u272.
The OWS version 1.4.0 will contain an updated JRE which should contain TLS 1.3 support.
Release is planned for April 2021.
by Stephan Classen
25 Feb 2021, 11:02
Forum: Public Forums
Topic: Running web jnlp on Ubuntu 18.04 LTS 64 - Can't load library:ibglassgtk3.so
Replies: 9
Views: 690

Re: Running web jnlp on Ubuntu 18.04 LTS 64 - Can't load library:ibglassgtk3.so

Can you share the JNLP with us. The error suggests that either a the native lib is not found or the method which the java code is trying to invoke cannot be found. There are two likely causes. JavaFX is not referenced correctly in the JNLP (hence we want to take a look at that file) Or you have an i...
by Stephan Classen
23 Feb 2021, 17:06
Forum: Public Forums
Topic: [SOLVED] Prevent running application if one of the jar-s not downloaded correctly
Replies: 2
Views: 248

Re: Prevent running application if one of the jar-s not downloaded correctly

Sorry so far there is no such option.
Mainly because for some application it is ok if not all the resources are available.
by Stephan Classen
22 Feb 2021, 15:20
Forum: Public Forums
Topic: [SOLVED] Codebase warning foreign domain
Replies: 8
Views: 532

Re: [SOLVED] Codebase warning foreign domain

Yes this is currently missing.
We will add this property with the next release of OWS
by Stephan Classen
21 Feb 2021, 16:12
Forum: Public Forums
Topic: [SOLVED] JNLP File with APPLET is not getting launched
Replies: 1
Views: 228

Re: JNLP File with APPLET is not getting launched

Yes, OpenWebStart does no longer support applets.
You will need to convert the your applet to an application.
by Stephan Classen
19 Feb 2021, 13:20
Forum: Public Forums
Topic: [SOLVED] Codebase warning foreign domain
Replies: 8
Views: 532

Re: Codebase warning foreign domain

In the deployment.properties (per user or system wide) you can add the following line:

deployment.security.level=ALLOW_UNSIGNED

This will disable a series of security checks including the one causing the warning you see
by Stephan Classen
19 Feb 2021, 11:51
Forum: Public Forums
Topic: [SOLVED] Codebase warning foreign domain
Replies: 8
Views: 532

Re: Codebase warning foreign domain

You can safe the decision by selecting the checkbox on the very bottom of the dialog.
by Stephan Classen
12 Feb 2021, 14:00
Forum: Public Forums
Topic: Running web jnlp on Ubuntu 18.04 LTS 64 - Can't load library:ibglassgtk3.so
Replies: 9
Views: 690

Re: Running web jnlp on Ubuntu 18.04 LTS 64 - Can't load library:ibglassgtk3.so

I don't think downgrading is the solution. But I am kind of running out of ideas.

Just to state the obvious:
Can you check that the file /usr/lib/jvm/java-1.8.0-amazon-corretto/jre/lib/amd64/libglassgtk3.so exists and is readable by the user which is starting the JNLP
by Stephan Classen
12 Feb 2021, 11:08
Forum: Public Forums
Topic: Running web jnlp on Ubuntu 18.04 LTS 64 - Can't load library:ibglassgtk3.so
Replies: 9
Views: 690

Re: Running web jnlp on Ubuntu 18.04 LTS 64 - Can't load library:ibglassgtk3.so

Can you start the application locally (without webstart) using the exact same JVM (/usr/lib/jvm/java-1.8.0-amazon-corretto/bin/java)
JavaFX and JVM 1.8.0 with a bugfix version greater than 200 (in your case this is 282) are known to have problems
by Stephan Classen
12 Feb 2021, 09:37
Forum: Public Forums
Topic: Running web jnlp on Ubuntu 18.04 LTS 64 - Can't load library:ibglassgtk3.so
Replies: 9
Views: 690

Re: Running web jnlp on Ubuntu 18.04 LTS 64 - Can't load library:ibglassgtk3.so

Also when you enable log to file there are always 2 log files created. "stage1" and "stage2".
In the stage1 log file you can find the command which is used to launch stage2. This command includes the path to the JVM for stage 2 so you can make sure that expected/required JVM is used.