IE does not "Open" jnlpx content

The public knowledge pool and discussion forum of the OWS community. Do not post confidential information here!
javaapp
Posts: 28
Joined: 20 May 2020, 18:34

IE does not "Open" jnlpx content

Post by javaapp »

We are seeing an issue with Internet Explorer (surprise) 11. We have associated only the "jnlpx" extension to OpenWebStart, not "jnlp" (on purpose). When we download a .jnlpx file to the browser, we get a popup at the bottom saying:

"Do you want to open or save filename.jnlpx (2.40 KB) from hostname.com? [Open] [Save] [Cancel]"
  • If we Save and and the double-click the jnlpx, OpenWebStart starts up and runs the app and all is well.
  • If we click Open, then nothing happens at all
  • If we choose "Save and Open" (from the "Save" dropdown), then nothing happens at all
The response headers we use are:

Code: Select all

Content-Disposition: attachment; filename="filename.jnlpx"
Content-Type: application/x-java-jnlp-file; charset=UTF-8
Ideally clicking "Open" (or "Save and Open") would invoke OpenWebstart and start our app. Any ideas?

Andreas Ehret
Posts: 27
Joined: 25 Mar 2020, 12:21

Re: IE does not "Open" jnlpx content

Post by Andreas Ehret »

To narrow down the problem, do you have the same behavior when you associate ".jnlp" extension in your IE11 to OpenWebStart, or does this combination behaves as expected?

Janak Mulani
Posts: 89
Joined: 24 Mar 2020, 13:37

Re: IE does not "Open" jnlpx content

Post by Janak Mulani »

I tested it and it works => in IE 11 type the URL of .jnlpx file, IE downloads it and asks for Open or Save, Clicking on Open starts the .jnlpx file with OWS.

In Windows Setting > Apps > Default Apps > Choose apps by file type >:.jnlpx is associated with OWS.:

jnlpx.PNG
jnlpx.PNG (18.31 KiB) Viewed 118 times

javaapp
Posts: 28
Joined: 20 May 2020, 18:34

Re: IE does not "Open" jnlpx content

Post by javaapp »

Using .jnlp extension had the same (bad) result for me. However if I assoociate .jnlp with Oracle's Java WebStart then it worked.

I'm wondering if my problem is environmental; my control panel shows 4 instances of OWS installed including 1.1.7 and 3 instances of 1.1.8. I'll get these cleaned out by a sys admin and re-install/re-test

Thanks for looking at this!

javaapp
Posts: 28
Joined: 20 May 2020, 18:34

Re: IE does not "Open" jnlpx content

Post by javaapp »

I forgot to mention: My co-worker is having the same problem as me. It wouldn't matter if OWS is installed per-user instead of for all users on the machine, right?

javaapp
Posts: 28
Joined: 20 May 2020, 18:34

Re: IE does not "Open" jnlpx content

Post by javaapp »

For me, In Windows Setting > Apps > Default Apps, there are three identical-looking OWS choices. I have installed and re-installed OWS many times on my local box for my evaluation which may explain this. Each time was "For just this user" since I do not have admin privileges on my box.

I've tried selecting all of the OWS choices as the Default app for .jnlpx but I get the same result in IE 11.

I'll have a sys admin uninstall all of these OWS instances and try to re-install and retest with a clean setup.

Hendrik Ebbers
Posts: 21
Joined: 02 Apr 2020, 10:11

Re: IE does not "Open" jnlpx content

Post by Hendrik Ebbers »

Do you have any feedback?

Post Reply