[SOLVED] JViewer applet not working

The public knowledge pool and discussion forum of the OWS community. Do not post confidential information here!
Posts: 2
Joined: 10 Nov 2020, 19:35

[SOLVED] JViewer applet not working

Post by groo1984 »

Hi all,

I'm very new to this and I'm super grateful to OWS as it let me run applications that otherwise I would not be able to because of limitations.
However, I'm unable to run a JViewer applet, as it seems that it cannot pull some libraries. I have attached the error log that I get when running the applet. Sorry for a lack of a detailed explanation, this is completely new to me. Would you be able to point me to the right direction?

Here is the log:

net.sourceforge.jnlp.LaunchException: Fatal: Launch Error: Could not launch JNLP file. The application has not been initialized, for more information execute javaws/browser from the command line and send a bug report.
at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:408)
at net.sourceforge.jnlp.Launcher.access$200(Launcher.java:70)
at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:654)
Caused by: java.lang.reflect.InvocationTargetException
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:566)
at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:401)
... 2 more
Caused by: java.lang.ExceptionInInitializerError
at com.ami.kvm.jviewer.JViewer.redirect(JViewer.java:252)
at com.ami.kvm.jviewer.JViewer.main(JViewer.java:137)
... 7 more
Caused by: java.lang.IndexOutOfBoundsException: Index -1 out of bounds for length 18
at java.base/jdk.internal.util.Preconditions.outOfBounds(Preconditions.java:64)
at java.base/jdk.internal.util.Preconditions.outOfBoundsCheckIndex(Preconditions.java:70)
at java.base/jdk.internal.util.Preconditions.checkIndex(Preconditions.java:248)
at java.base/java.util.Objects.checkIndex(Objects.java:372)
at java.base/java.util.ArrayList.get(ArrayList.java:458)
at com.ami.kvm.jviewer.gui.StandAloneConnectionDialog.getSupportedLocales(StandAloneConnectionDialog.java:1229)
at com.ami.kvm.jviewer.gui.JVMenu.constructOptionsMenu(JVMenu.java:1389)
at com.ami.kvm.jviewer.gui.WindowMenu.constructUserIf(WindowMenu.java:65)
at com.ami.kvm.jviewer.gui.WindowMenu.<init>(WindowMenu.java:43)
at com.ami.kvm.jviewer.gui.WindowFrame.constructUserIf(WindowFrame.java:233)
at com.ami.kvm.jviewer.gui.WindowFrame.<init>(WindowFrame.java:57)
at com.ami.kvm.jviewer.gui.JViewerApp.constructUI(JViewerApp.java:677)
at com.ami.kvm.jviewer.gui.JViewerApp.<init>(JViewerApp.java:667)
at com.ami.kvm.jviewer.gui.JViewerApp.<clinit>(JViewerApp.java:529)
... 9 more

Stephan Classen
Posts: 202
Joined: 27 Mar 2020, 09:55

Re: JViewer applet not working

Post by Stephan Classen »

Hi and thank you for using OWS.

I am sorry but the exception is coming from the JViewer Code.
A quick search with google did not find anything useful you could try.
I guess your best option is to contact the developers of JViewer and ask for help

Posts: 2
Joined: 10 Nov 2020, 19:35

Re: JViewer applet not working

Post by groo1984 »

Thanks very much Stephan. I have tried looking in Google too but was unable to find anything meaningful, so it was worth a shot to ask here, if anybody faced a similar problem.
I will check with the code developers and if something is found I will post it here, it may be of help to others.

Thanks very much once again!



Post Reply