Proxy warning on Mac

The public knowledge pool and discussion forum of the OWS community. Do not post confidential information here!
Janak Mulani
Posts: 140
Joined: 24 Mar 2020, 13:37

Proxy warning on Mac

Post by Janak Mulani »

For OWS Default Proxy Setting i.e. "System Proxy", OWS is showing the following warning:
Proxywarning.PNG
Proxywarning.PNG (56.74 KiB) Viewed 664 times
With OWS "No Proxy" settings the warning is not shown.

Is it possible to configure "No proxy" Setting in the response.varfile?

Janak Mulani
Posts: 140
Joined: 24 Mar 2020, 13:37

Re: Proxy warning on Mac

Post by Janak Mulani »

OWS uses scutil to get Proxy information on Mac when "System Proxy" setting is specified. Some of the proxy settings may not be supported and hence the warning.

"System Proxy" is the default proxy setting for OWS..

You can override the default proxy setting of OWS at installation by specifying the setting of your choice in the response.varfile.

The properties tha can be specified in response.varfile are listed at https://openwebstart.com/configuration/

In the response.varfile you can specify the proxy type that should be used.with property deployment.proxy.type. Its values are: 0 (No proxy), 1 (Manual proxy), 2 (PAC based proxy), 3 (Firefox), 4 (System proxy, default. Default value is not shown in deployment.properties file).

Hendrik Ebbers
Posts: 22
Joined: 02 Apr 2020, 10:11

Re: Proxy warning on Mac

Post by Hendrik Ebbers »

The specific warning that is shown in the dialog is based on the shown proxy settings configuration in MacOS. We should check if this is active by default (even if no other proxy setting is active in MacOS) and ignore it in such case.
Attachments
proxy.png
proxy.png (442.83 KiB) Viewed 634 times

vijayasri.t
Posts: 13
Joined: 27 Jul 2020, 12:48

Re: Proxy warning on Mac

Post by vijayasri.t »

Hello,

I have this same issue on my macBook. The warning prompt shows up twice during the application launch. OWS working with default setting of System Proxy. To get rid of the message, the only option I have is to set it to No Proxy in OWS Settings. It doesnt seem to honor whether Use Passive FTP Mode (PASV) is checked or unchecked in Network > Proxies.
Users who are on Windows and accessing the application dont see the prompt with System Proxy setting.

Thanks,
Vijayasri

Janak Mulani
Posts: 140
Joined: 24 Mar 2020, 13:37

Re: Proxy warning on Mac

Post by Janak Mulani »

We already have an issue for this. we will try to solve it in the upcoming release 1.2.0 planned in August.

vijayasri.t
Posts: 13
Joined: 27 Jul 2020, 12:48

Re: Proxy warning on Mac

Post by vijayasri.t »

Thanks for the info!


Post Reply