JNLP File with APPLET is not getting launched

The public knowledge pool and discussion forum of the OWS community. Do not post confidential information here!
kambidi@gmail.com
Posts: 1
Joined: 21 Feb 2021, 13:37

JNLP File with APPLET is not getting launched

Post by kambidi@gmail.com »

Hi All,
Greetings!
This is my first post, I'm trying to open a JNLP file with OpenWebStart, but blocked because of Iced Tea Web not displaying the login screens of the application. Here's my JNLP file, I'm not able launch it successfully. Any suggestion would be appraciciated

<?xml version="1.0" encoding="utf-8"?>
<jnlp spec="7.0" version="12.5.1.11001-348" href="rtr"
codebase="https://obusecase-uccx1-151.cisco.com/a ... reporting/">

<information>
<title>UCCX Real Time Reporting</title>
<vendor>Cisco</vendor>
<description kind="short">Unified CCX Real Time Reporting</description>
</information>
<security>
<all-permissions/>
</security>
<update check="background" policy="prompt-update"/>
<resources>
<j2se version="1.7+" href="http://java.sun.com/products/autodl/j2se" max-heap-size="256m"/>
<jar href="sWFReportingCommon.jar"/>
<jar href="sCiscoWFAPI1.0.jar"/>
<jar href="sCiscoWFFBase.jar"/>
<jar href="sCiscoWFFRemoteEngineStub.jar"/>
<jar href="sCiscoWFFRemoteEngineIntf.jar"/>
<jar href="sCiscoWFFEngine.jar"/>
<jar href="sCiscoRemoteEngineSvc.jar"/>
<jar href="sSubsystemEDBS.jar"/>
<jar href="sSubsystemCoreRTR.jar"/>
<jar href="sSubsystemRmCm.jar"/>
<jar href="sSubsystemRouteAndQueue.jar"/>
<jar href="sRemoteSubsystemRmCm.jar"/>
<jar href="sRemoteSubsystemOutbound.jar"/>
<jar href="sRemoteSubSystemEDBS.jar"/>
</resources>
<applet-desc name="rtr-obusecase-uccx1-151.cisco.com" width="1600" height="1200"
documentBase="https://obusecase-uccx1-151.cisco.com/a ... reporting/"
main-class="com.cisco.wfframework.reporting.ui.applet.ReportApplet">
<param name="MDI_INTERFACE" value="false" />
<param name="DATA_HOST" value="obusecase-uccx2-152.cisco.com|2||obusecase-uccx1-151.cisco.com|1||" />
<!--EDCS-430157 replacement of controller.getRMIPort() for controller.getLDAPEngineConfiguration()).getRMIPort() -->
<param name="DATA_PORT" value="6999" />
<param name="IAQ_INSTALLED" value="true" />
<param name="ENABLE_ICD_STATS" value="true" />
<param name="ENABLE_OB_STATS" value="true" />
<param name="ENABLE_OBIVR_STATS" value="true" />
<param name="ENABLE_CHAT_STATS" value="true" />
<param name="ENABLE_DB" value="true" />
<param name="RTR_TRACE_INFO" value="false" />
<param name="RTR_TRACE_DEBUG" value="false" />
<param name="RTR_TRACE_CORERTR" value="false" />
<param name="RTR_TRACE_EDBS" value="false" />
<param name="PRIMARY_TIMEZONE" value="Asia/Kolkata" />
<param name="DATA_IP_HOST_NAME" value="obusecase-uccx2-152.cisco.com|obusecase-uccx2-152||obusecase-uccx1-151.cisco.com|obusecase-uccx1-151||" />
<param name="DATA_IS_HOST_NAME" value="false" />
</applet-desc>
</jnlp>

Stephan Classen
Posts: 139
Joined: 27 Mar 2020, 09:55

Re: JNLP File with APPLET is not getting launched

Post by Stephan Classen »

Yes, OpenWebStart does no longer support applets.
You will need to convert the your applet to an application.

Post Reply