Security settings partially greyed out

The public knowledge pool and discussion forum of the OWS community. Do not post confidential information here!
jeroen
Posts: 2
Joined: 14 Jun 2021, 16:44

Security settings partially greyed out

Post by jeroen »

Hi

Doing a standard install of version 1.4.0 (64bits, run as administrator, for all users) we sometimes end up with the security settings partially being greyed out.
security.png
security.png (8.34 KiB) Viewed 495 times
Any idea what might be the problem.
User has administrator rights.

Best regards
Jeroen

Janak Mulani
Posts: 232
Joined: 24 Mar 2020, 13:37

Re: Security settings partially greyed out

Post by Janak Mulani »

Hi Jeroen,

Can you please tell us the exact steps to reproduce this? I.e you installed, started itw-settings and found that security options are greyed?

Have by any chance locked those properties? https://openwebstart.com/docs/OWSGuide. ... a_property

Can you check if in your deployment.properties if those security properties are locked? You can remove the lock property for those properties.

Can you please share your deployment.properties?

Stephan Classen
Posts: 183
Joined: 27 Mar 2020, 09:55

Re: Security settings partially greyed out

Post by Stephan Classen »

Also can you check if there is a system wide properties file:
https://openwebstart.com/docs/OWSGuide. ... figuration

jeroen
Posts: 2
Joined: 14 Jun 2021, 16:44

Re: Security settings partially greyed out

Post by jeroen »

Hi all

Sorry for the late feedback, but there were indeed some remnants in <Windows Directory>\Sun\Java\Deployment\deployment.config , from another Java deployment I guess, which interfered.
Thanks for pointing us in the right direction.

Best regards
Jeroen

Janak Mulani
Posts: 232
Joined: 24 Mar 2020, 13:37

Re: Security settings partially greyed out

Post by Janak Mulani »

FYI you can have OWS specific deployment.config. Please see
https://openwebstart.com/docs/OWSGuide. ... figuration.

Post Reply