Page 1 of 1

OpenWebStart Support for RHEL

Posted: 12 Jul 2021, 16:55
by aggarwalyogesh786
Hi All,

I have installed OWS on RHEL8.4 but after installing it, all the screens are blank and without any text due to which it is impossible to operate.

Does anyone has any suggestions?

Re: OpenWebStart Support for RHEL

Posted: 14 Jul 2021, 18:05
by aggarwalyogesh786
Any feedback guys?

Re: OpenWebStart Support for RHEL

Posted: 15 Jul 2021, 09:01
by Janak Mulani
Can you please describe which screens are blank? Do you mean screens of itw-settings tool used to configure OWS?

Are you able to start any Jnlp application?

Re: OpenWebStart Support for RHEL

Posted: 15 Jul 2021, 12:51
by aggarwalyogesh786
Janak Mulani wrote:
15 Jul 2021, 09:01
Can you please describe which screens are blank? Do you mean screens of itw-settings tool used to configure OWS?

Are you able to start any Jnlp application?
Hi,

Please see the attached snapshots.

Re: OpenWebStart Support for RHEL

Posted: 16 Jul 2021, 11:34
by Andreas Ehret
Was this your first try with OWS 1.4.0 on RHEL8.4 or did it work before (older version of OWS resp. RHEL)?

Re: OpenWebStart Support for RHEL

Posted: 19 Jul 2021, 06:29
by aggarwalyogesh786
Andreas Ehret wrote:
16 Jul 2021, 11:34
Was this your first try with OWS 1.4.0 on RHEL8.4 or did it work before (older version of OWS resp. RHEL)?
Hi Andreas,

Thank you for writing.

Yes, this was my first try.

Re: OpenWebStart Support for RHEL

Posted: 22 Jul 2021, 15:12
by Janak Mulani
Hi

Unfortunately we do not have a RHEL machine to reproduce your issue.

Can you please send us the logs? https://openwebstart.com/docs/OWSGuide.html#_logging

Re: OpenWebStart Support for RHEL

Posted: 26 Jul 2021, 06:10
by aggarwalyogesh786
Janak Mulani wrote:
22 Jul 2021, 15:12
Hi

Unfortunately we do not have a RHEL machine to reproduce your issue.

Can you please send us the logs? https://openwebstart.com/docs/OWSGuide.html#_logging
Hi,

I am not able to open even OpenWebStart Settings to capture the logs because of this issue.

Re: OpenWebStart Support for RHEL

Posted: 26 Jul 2021, 08:13
by Andreas Ehret
can you add the following lines

deployment.log.file=true
deployment.log=true
deployment.console.startup.mode=SHOW

to your "/home/<your user>/.config/icedtea-web/deployment.properties" file to enable logging manually without using the UI.
If you do this, OWS should log to file (/home/<your user>/.config/icedtea-web/log) when you startup your app.

After enabling and startup you should see state1* and stage2" log files in this folder.

Re: OpenWebStart Support for RHEL

Posted: 02 Aug 2021, 09:05
by aggarwalyogesh786
Andreas Ehret wrote:
26 Jul 2021, 08:13
can you add the following lines

deployment.log.file=true
deployment.log=true
deployment.console.startup.mode=SHOW

to your "/home/<your user>/.config/icedtea-web/deployment.properties" file to enable logging manually without using the UI.
If you do this, OWS should log to file (/home/<your user>/.config/icedtea-web/log) when you startup your app.

After enabling and startup you should see state1* and stage2" log files in this folder.
Hi Andreas,
Thank you so much. I am able to gather the logs. However, I am not sure why we cannot see anything on the screen. Can I attach the logs if someone can help?

Re: OpenWebStart Support for RHEL

Posted: 03 Aug 2021, 12:47
by Janak Mulani
Please send us your logs and also your deployment.properties file.