itw-settings.exe wont open

Get help with installation and configuration of OWS. Please post specific bug reports, pull requests, or source code extensions on github.
ChrisG81
Posts: 1
Joined: 26 Aug 2020, 11:52

itw-settings.exe wont open

Post by ChrisG81 »

Hey,

im having trouble with the latest Update of OWS. After Upgrading to Version 1.2.1 the itw.settings application will not open as long as the user does not have Administrator priviliges.

Things i did do already:

- Complete Removal of the Program and Check if there is an installaton left under any of the Users wich would use that Computer
- Reboot
- New installation using the account of domain\administrator

itw-settings will open as Administrator, as soon as the user logs in to change the Stuff wich is needed to start up applications, it will just show the initial loading screen and then nothing happens.

Best Regards

Christian

Janak Mulani
Posts: 741
Joined: 24 Mar 2020, 13:37

Re: itw-settings.exe wont open

Post by Janak Mulani »

Hi Christian,

We will try to reproduce the issue, investigate and come back to you.

Can you send us the log file?

Thanks for reporting

- Janak

ptai
Posts: 13
Joined: 13 Aug 2020, 14:50

Re: itw-settings.exe wont open

Post by ptai »

I have the same problem currently, when starting itw-settings.exe, only the splah-screen appears but then nothing happens.

I am on a updated Windows 10 with OWS Version 1.7.0. I did try to start as administrator whit the same outcome.

This installation was working until the workstation had a power-outage, since then this state persists, no matter if it is de-installed and re-installed.

What log can I check/append here?

Thank you

Janak Mulani
Posts: 741
Joined: 24 Mar 2020, 13:37

Re: itw-settings.exe wont open

Post by Janak Mulani »

You can attach the <date-time>-ows-settings.log file.

Is your deployment.properties file corrupted by any chance? You could rename that file and try starting itw-settings.

ptai
Posts: 13
Joined: 13 Aug 2020, 14:50

Re: itw-settings.exe wont open

Post by ptai »

I tested both with adapted deployment.properties and without any deployment.properties. Both did not open the settings dialog with the same exception, some JSON can't be parsed successfully.

Here are the logs for the two test-runs. The earlier log was done with the adapted deployment.properties.

In the first log, there is also this info:
Property 'ows.checkUpdate' is unknown

But this is a valid property given your listing here:
https://openwebstart.com/docs/OWSGuide. ... s_overview

I then cleared the cache with:
javaws.exe -Xclearcache

The log of that run is also attached.

I also deleted the .../.config/icedtea-web folder as also the installation folder manually and then did a re-install. Nothing changed the state so far.

Any ideas which JSON can't be parsed?
Attachments
2023-03-07_17_30_42.33-ows-stage1.log
(1.91 KiB) Downloaded 367 times
2023-03-07_17_17_28.219-ows-settings.log
(9.92 KiB) Downloaded 364 times
2023-03-07_17_10_50.211-ows-settings.log
(9.9 KiB) Downloaded 373 times

Janak Mulani
Posts: 741
Joined: 24 Mar 2020, 13:37

Re: itw-settings.exe wont open

Post by Janak Mulani »

Code: Select all

 Exception in thread "AWT-EventQueue-0" com.openwebstart.google.gson.JsonSyntaxException: Error in JSON conversion
[ITW-APP ][2023-03-07 17:17:28.837 CET][ERROR][sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:221)] 	at com.openwebstart.jvm.json.JsonHandler.fromJson(JsonHandler.java:36)
[ITW-APP ][2023-03-07 17:17:28.837 CET][ERROR][sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:221)] 	at com.openwebstart.jvm.LocalRuntimeManager.loadRuntimes(LocalRuntimeManager.java:147)
[ITW-APP ][2023-03-07 17:17:28.838 CET][ERROR][sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:221)] 	at com.openwebstart.jvm.JavaRuntimeManager.reloadLocalRuntimes(JavaRuntimeManager.
It seems your jvm cache json <UserHome>\.cache\icedtea-web\jvm-cache\cache.json could be corrupted.

Please delete the .jvm-cache dir and then run itw-settings.

ptai
Posts: 13
Joined: 13 Aug 2020, 14:50

Re: itw-settings.exe wont open

Post by ptai »

Thank you, deleting the jvm-cache folder fixed it.

What exactly did the "javaws.exe -Xclearcache" command clear? I assumed it will get rid of all the cached data.

Janak Mulani
Posts: 741
Joined: 24 Mar 2020, 13:37

Re: itw-settings.exe wont open

Post by Janak Mulani »

> What exactly did the "javaws.exe -Xclearcache" command clear? I assumed it will get rid of all the cached data.

It clears the applications cache - all the cached jnlps and jars.

jvm-cache is for caching the downloaded jvms that are used to run jnlp applications.

Post Reply