Application not launching - looks like looping behavior

The public knowledge pool and discussion forum of the OWS community. Do not post confidential information here!
magnusska
Posts: 16
Joined: 24 Feb 2023, 16:11

Application not launching - looks like looping behavior

Post by magnusska »

I'm trying to launch an application with a jnlp file that works fine with javaws in 1.8.
The source code has been modified to comply with OWS/IcedTea.

jnlp:

Code: Select all

<?xml version="1.0" encoding="UTF-8" ?>
<jnlp spec="6.0.10+" href="larm.jnlp" codebase="https://mms-sn-nattbygg1-klient-fifty-cm-mms-endpoints.apps.stas-test.statnett.no/larm/">
  <information>
    <title>Fifty (@https://xxxx.statnett.no)</title>
    <vendor>Fifty</vendor>
    <homepage>https://xxxx.statnett.no/larm</homepage>
    <description>Fifty Intern</description>
    <icon href="img/applicationIcon.png" />
    <icon href="img/applicationIcon.png" kind="splash" />
    <icon href="img/applicationIcon.ico" kind="shortcut" />
  </information>
  <security>
    <all-permissions />
  </security>
  <update check="always" />
  <resources os="Windows" arch="x86">
    <j2se version="11" href="http://java.sun.com/products/autodl/j2se"  initial-heap-size="1G" max-heap-size="4G" java-vm-args="-Xss2m -XX:+HeapDumpOnOutOfMemoryError" />
  </resources>
  <resources>
  <j2se version="11" initial-heap-size="1G" max-heap-size="4G" java-vm-args="-Xss2m -XX:+HeapDumpOnOutOfMemoryError" />
    <jar href="statnett-fifty-intern-client-xxx.jar" version="29.14.3.6-SNAPSHOT.20230227113539"/>
    <property name="jnlp.versionEnabled" value="true"/>
  </resources>
  <application-desc main-class="no.statnett.fifty.intern.client.ApplicationStarter" name="Fifty (@https://xxxx.statnett.no)" >
    <argument>https://xxxx.statnett.no/larm</argument>
  </application-desc>
</jnlp>
Exerpt from console looks like this:

Code: Select all

Waiting for exception dialog to be closed
Launch exception
netx: Launch Error: Could not launch JNLP file. ( ())
Using MalformedXMLParser
APPLICATION_TEMPLATE.JNLP has been located within signed JAR. Starting verification...
Creating File InputStream from launching JNLP file
Creating Jar InputStream from JarEntry
App already has trusted publisher: true
..... REPEATS MANY TIMES......
Using MalformedXMLParser
APPLICATION_TEMPLATE.JNLP has been located within signed JAR. Starting verification...
Creating File InputStream from launching JNLP file
Creating Jar InputStream from JarEntry
App already has trusted publisher: true
Using MalformedXMLParser
APPLICATION_TEMPLATE.JNLP has been located within signed JAR. Starting verification...
Creating File InputStream from launching JNLP file
Closing DownloadServiceListener
Creating Jar InputStream from JarEntry
App already has trusted publisher: true
Using MalformedXMLParser
APPLICATION_TEMPLATE.JNLP has been located within signed JAR. Starting verification...
Creating File InputStream from launching JNLP file
Creating Jar InputStream from JarEntry
App already has trusted publisher: true
Using MalformedXMLParser
APPLICATION_TEMPLATE.JNLP has been located within signed JAR. Starting verification...
Creating File InputStream from launching JNLP file
Creating Jar InputStream from JarEntry
App already has trusted publisher: true
Will add resource 'statnett-fifty-intern-client-xxx.jar'
Will add resource at location 'https://xxxx.statnett.no/larm/statnett-fifty-intern-client-xxx.jar'
Class-Path attribute cleared for C:\Users\magnusska\.cache\icedtea-web\cache\0\3\statnett-fifty-intern-client-xxx.jar
12:12:07.413 [Fifty (@https://xxxx.statnett.no)] DEBUG fifty.core.util.i18n.Messages - Laster resource bundle for locale nb_NO. Konfigurasjonskatalog er C:\Users\magnusska\fifty 
Reading Shortcuts with UTF-8
Using WindowsShortCutManager C:\Users\magnusska\.cache\icedtea-web\cache\shortcutList.txt
Invoking main() with args: [https://xxxx.stas-test.statnett.no/larm]
Setting net.sourceforge.jnlp.runtime.classloader.JNLPClassLoader@64a76175 as the classloader for thread TimerQueue
Setting net.sourceforge.jnlp.runtime.classloader.JNLPClassLoader@64a76175 as the classloader for thread AWT-EventQueue-1
Setting net.sourceforge.jnlp.runtime.classloader.JNLPClassLoader@64a76175 as the classloader for thread Fifty (@https://mms-sn-nattbygg1-klient-fifty-cm-mms-endpoints.apps.stas-test.statnett.no)
Cached desktop shortcut icon: C:\Users\magnusska\.config\icedtea-web\icons\applicationIcon.ico ,  With source from: C:\Users\magnusska\.cache\icedtea-web\cache\0\8\applicationIcon.ico
Download done. Shutting down executor

Janak Mulani
Posts: 564
Joined: 24 Mar 2020, 13:37

Re: Application not launching - looks like looping behavior

Post by Janak Mulani »

Which version of OWS are you using? Can you please post the OWS logs?

magnusska
Posts: 16
Joined: 24 Feb 2023, 16:11

Re: Application not launching - looks like looping behavior

Post by magnusska »

Log files attached
Attachments
2023-03-02_14_05_36.256-ows-stage2.log
(204.7 KiB) Downloaded 107 times
2023-03-02_14_05_36.256-ows-stage1.log
(5.84 KiB) Downloaded 108 times

Janak Mulani
Posts: 564
Joined: 24 Mar 2020, 13:37

Re: Application not launching - looks like looping behavior

Post by Janak Mulani »

You are using OWS 1.4.0 : Stage 1 log says "Starting OpenWebStart 1.4.0".

Please try with the latest version of OWS 1.7.0 and send the logs. Please enable debug level logging and logging content of jnlp.

magnusska
Posts: 16
Joined: 24 Feb 2023, 16:11

Re: Application not launching - looks like looping behavior

Post by magnusska »

The problem persists after upgrade to OWS 1.7.0
Log files attached.
Attachments
2023-03-21_09_27_19.2-ows-stage2.log
(402.33 KiB) Downloaded 18 times
2023-03-21_09_27_19.2-ows-stage1.log
(31.24 KiB) Downloaded 19 times

magnusska
Posts: 16
Joined: 24 Feb 2023, 16:11

Re: Application not launching - looks like looping behavior

Post by magnusska »

I'm wondering if any of the java-vm-args have been obsoleted:

Code: Select all

  <resources os="Windows" arch="x86">
    <j2se version="11" href="http://java.sun.com/products/autodl/j2se"  initial-heap-size="1G" max-heap-size="4G" java-vm-args="-Xss2m -XX:+HeapDumpOnOutOfMemoryError" />
  </resources>
  <resources>
  <j2se version="11" initial-heap-size="1G" max-heap-size="4G" java-vm-args="-Xss2m -XX:+HeapDumpOnOutOfMemoryError" />
    <jar href="statnett-fifty-intern-client-jar-with-dependencies.jar" version="29.14.4.5-SNAPSHOT.20230321083431"/>
    <property name="jnlp.versionEnabled" value="true"/>
    <!--property name="jnlp.mfrr.cm.visible" value="true"/-->
  </resources>
Also logs/console show this:
Warning - your JRE - 11.0.11 - does not match requested JRE - 11

magnusska
Posts: 16
Joined: 24 Feb 2023, 16:11

Re: Application not launching - looks like looping behavior

Post by magnusska »

This is the repeating section of the log:

Code: Select all

[ITW-CORE][2023-03-23 12:33:54.673 CET][DEBUG][net.sourceforge.jnlp.tools.JarCertVerifier] App is signed: true
[ITW-CORE][2023-03-23 12:33:54.677 CET][DEBUG][net.sourceforge.jnlp.runtime.classloader.JNLPClassLoader] Creating Jar InputStream from JarEntry
[ITW-CORE][2023-03-23 12:33:54.844 CET][DEBUG][net.sourceforge.jnlp.runtime.classloader.JNLPClassLoader] Creating File InputStream from launching JNLP file
[ITW-CORE][2023-03-23 12:33:54.844 CET][DEBUG][net.adoptopenjdk.icedteaweb.lockingfile.LockableFile] Trying to create lock file C:\Users\magnusska\.cache\icedtea-web\cache\recently_used.cache.lock
[ITW-CORE][2023-03-23 12:33:54.845 CET][DEBUG][net.adoptopenjdk.icedteaweb.lockingfile.LockableFile] Created lock file C:\Users\magnusska\.cache\icedtea-web\cache\recently_used.cache.lock
[ITW-CORE][2023-03-23 12:33:54.847 CET][DEBUG][net.adoptopenjdk.icedteaweb.lockingfile.LockableFile] Deleted lock file C:\Users\magnusska\.cache\icedtea-web\cache\recently_used.cache.lock
[ITW-CORE][2023-03-23 12:33:54.848 CET][DEBUG][net.sourceforge.jnlp.runtime.classloader.JNLPClassLoader] APPLICATION_TEMPLATE.JNLP has been located within signed JAR. Starting verification...
[ITW-CORE][2023-03-23 12:33:54.848 CET][INFO ][net.adoptopenjdk.icedteaweb.xmlparser.MalformedXMLParser] Using MalformedXMLParser
[ITW-CORE][2023-03-23 12:33:54.856 CET][DEBUG][com.openwebstart.download.ApplicationDownloadIndicator] Closing DownloadServiceListener
[ITW-CORE][2023-03-23 12:33:54.872 CET][DEBUG][net.sourceforge.jnlp.tools.JarCertVerifier] App is signed: true
[ITW-CORE][2023-03-23 12:33:54.875 CET][DEBUG][net.sourceforge.jnlp.runtime.classloader.JNLPClassLoader] Creating Jar InputStream from JarEntry
[ITW-CORE][2023-03-23 12:33:55.034 CET][DEBUG][net.sourceforge.jnlp.runtime.classloader.JNLPClassLoader] Creating File InputStream from launching JNLP file
[ITW-CORE][2023-03-23 12:33:55.035 CET][DEBUG][net.adoptopenjdk.icedteaweb.lockingfile.LockableFile] Trying to create lock file C:\Users\magnusska\.cache\icedtea-web\cache\recently_used.cache.lock
[ITW-CORE][2023-03-23 12:33:55.036 CET][DEBUG][net.adoptopenjdk.icedteaweb.lockingfile.LockableFile] Created lock file C:\Users\magnusska\.cache\icedtea-web\cache\recently_used.cache.lock
[ITW-CORE][2023-03-23 12:33:55.037 CET][DEBUG][net.adoptopenjdk.icedteaweb.lockingfile.LockableFile] Deleted lock file C:\Users\magnusska\.cache\icedtea-web\cache\recently_used.cache.lock
[ITW-CORE][2023-03-23 12:33:55.038 CET][DEBUG][net.sourceforge.jnlp.runtime.classloader.JNLPClassLoader] APPLICATION_TEMPLATE.JNLP has been located within signed JAR. Starting verification...
[ITW-CORE][2023-03-23 12:33:55.038 CET][INFO ][net.adoptopenjdk.icedteaweb.xmlparser.MalformedXMLParser] Using MalformedXMLParser
[ITW-CORE][2023-03-23 12:33:55.063 CET][DEBUG][net.sourceforge.jnlp.tools.JarCertVerifier] App is signed: true
[ITW-CORE][2023-03-23 12:33:55.066 CET][DEBUG][net.sourceforge.jnlp.runtime.classloader.JNLPClassLoader] Creating Jar InputStream from JarEntry
[ITW-CORE][2023-03-23 12:33:55.232 CET][DEBUG][net.sourceforge.jnlp.runtime.classloader.JNLPClassLoader] Creating File InputStream from launching JNLP file
[ITW-CORE][2023-03-23 12:33:55.233 CET][DEBUG][net.adoptopenjdk.icedteaweb.lockingfile.LockableFile] Trying to create lock file C:\Users\magnusska\.cache\icedtea-web\cache\recently_used.cache.lock
[ITW-CORE][2023-03-23 12:33:55.234 CET][DEBUG][net.adoptopenjdk.icedteaweb.lockingfile.LockableFile] Created lock file C:\Users\magnusska\.cache\icedtea-web\cache\recently_used.cache.lock
[ITW-CORE][2023-03-23 12:33:55.236 CET][DEBUG][net.adoptopenjdk.icedteaweb.lockingfile.LockableFile] Deleted lock file C:\Users\magnusska\.cache\icedtea-web\cache\recently_used.cache.lock
[ITW-CORE][2023-03-23 12:33:55.236 CET][DEBUG][net.sourceforge.jnlp.runtime.classloader.JNLPClassLoader] APPLICATION_TEMPLATE.JNLP has been located within signed JAR. Starting verification...
[ITW-CORE][2023-03-23 12:33:55.237 CET][INFO ][net.adoptopenjdk.icedteaweb.xmlparser.MalformedXMLParser] Using MalformedXMLParser
[ITW-CORE][2023-03-23 12:33:55.257 CET][DEBUG][net.sourceforge.jnlp.tools.JarCertVerifier] App is signed: true

Janak Mulani
Posts: 564
Joined: 24 Mar 2020, 13:37

Re: Application not launching - looks like looping behavior

Post by Janak Mulani »

You have a jar file specified in your Jnlp file.

This jar file must have a JNLP-INF folder which must contain APPLICATION.TEMPLATE.JNLP.

Can you please send me the APPLICATION_TEMPLATE.JNLP?

You are running on Windows OS which is not x86, other jvm args are picked up.

Your jnlp is being launched with matching JVM 11 and JVM args look ok else there would be an error in log file and all jvm args would have been ignored: :

Code: Select all

"C:\Program Files\AdoptOpenJDK\jdk-11.0.11.9-hotspot\bin\java.exe" -Xbootclasspath/a:C:\dev\ows\OpenWebStart\openwebstart.jar -Dicedtea-web.bin.location=C:\dev\ows\OpenWebStart\javaws -Xms1G -Xmx4G -Xss2m -XX:+HeapDumpOnOutOfMemoryError -Djnlp.versionEnabled=true --add-exports=java.base/sun.net.www.protocol.jar=ALL-UNNAMED,java.desktop --add-exports=java.base/jdk.internal.util.jar=ALL-UNNAMED,java.desktop --add-exports=java.base/com.sun.net.ssl.internal.ssl=ALL-UNNAMED,java.desktop --add-reads=java.naming=ALL-UNNAMED,java.desktop --add-exports=java.desktop/sun.awt.X11=ALL-UNNAMED,java.desktop --add-exports=java.desktop/sun.applet=ALL-UNNAMED,java.desktop,jdk.jsobject --add-exports=java.base/sun.security.action=ALL-UNNAMED,java.desktop --add-reads=java.base=ALL-UNNAMED,java.desktop --add-exports=java.base/sun.net.www.protocol.http=ALL-UNNAMED,java.desktop --add-exports=java.naming/com.sun.jndi.toolkit.url=ALL-UNNAMED,java.desktop --add-exports=java.base/sun.security.util=ALL-UNNAMED,java.desktop --add-reads=java.desktop=ALL-UNNAMED,java.naming --add-exports=java.desktop/sun.awt=ALL-UNNAMED,java.desktop --add-exports=java.base/sun.security.x509=ALL-UNNAMED,java.desktop --add-exports=java.desktop/javax.jnlp=ALL-UNNAMED,java.desktop --add-exports=java.base/sun.security.provider=ALL-UNNAMED,java.desktop --add-exports=java.base/sun.security.validator=ALL-UNNAMED,java.desktop net.sourceforge.jnlp.runtime.Boot -Xnofork C:\Users\magnusska\Downloads\larm (86).jnlp
There seems to be some recursion / nesting of APPLICATION.TEMPLATE.JNLP in your jar file.

magnusska
Posts: 16
Joined: 24 Feb 2023, 16:11

Re: Application not launching - looks like looping behavior

Post by magnusska »

APPLICATION.TEMPLATE.JNLP:

Code: Select all

<?xml version="1.0" encoding="UTF-8" ?>
<jnlp spec="6.0.10+" href="larm.jnlp" codebase="*">
  <information>
    <title>*</title>
    <vendor>Fifty</vendor>
    <homepage>*</homepage>
    <description>*</description>
    <icon href="*" />
    <icon href="*" kind="splash" />
    <icon href="*" kind="shortcut" />
  </information>
  <security>
    <all-permissions />
  </security>
  <update check="always" />
  <resources os="*" arch="*">
    <j2se version="*" href="*" initial-heap-size="*" max-heap-size="*" java-vm-args="-Xss2m -XX:+HeapDumpOnOutOfMemoryError" />
  </resources>
  <resources>
    <j2se version="*" initial-heap-size="*" max-heap-size="*" java-vm-args="-Xss2m -XX:+HeapDumpOnOutOfMemoryError" />
    <jar href="*" version="*"/>
    <property name="jnlp.versionEnabled" value="true"/>
  </resources>
  <application-desc main-class="*" name="*" >
    <argument>*</argument>
  </application-desc>
</jnlp>

Janak Mulani
Posts: 564
Joined: 24 Mar 2020, 13:37

Re: Application not launching - looks like looping behavior

Post by Janak Mulani »

Can you share your APPLICATION.JNLP?

What are the contents of your jar i.e. the directory structure within the jar and contents of JNLP-INF and META-INF folder and manifest?

magnusska
Posts: 16
Joined: 24 Feb 2023, 16:11

Re: Application not launching - looks like looping behavior

Post by magnusska »

I can't find APPLICATION.JNLP

I removed "JavaWebStartServices.installShortcut();"
Same problem.

Code: Select all

    public static void main(String[] args) throws Exception { // NOSONAR
        Locale.setDefault(new Locale("nb", "NO"));
        System.setProperty("app.log.dir", "fifty");
        JavaWebStartServices.installShortcut();

        Arbeidsflate arbeidsflate = new InternArbeidsflate();

        new ArbeidsflateStarter(arbeidsflate, AuthSchemes.DIGEST).startMedArgs(args);
    }
Debugging "new InternArbeidsflate();" next

Janak Mulani
Posts: 564
Joined: 24 Mar 2020, 13:37

Re: Application not launching - looks like looping behavior

Post by Janak Mulani »

Of course, you either have the APPLICATION.JNLP or the APPLICATION_TEMPLATE.JNLP. You have the latter.

I tried creating a sample signed jnlp like yours. See attached. I could not reproduce your issue.

In your case too the jar is processed, APPLICATION_TEMPLATE.JNLP is found and processed and then app is started (Stage 2 log Line 313)

Code: Select all

Invoking main() with args: [https://mms-sn-nattbygg1-klient-fifty-cm-mms-endpoints.apps.stas-test.statnett.no/larm]
But after that at line 318/9 OWS is again trying to process your jar file which has already been done at line 209 and then it finds APPLICATION_TEMPLATE.JNLP and seems to go into loop.

Code: Select all

Create resource for 'https://mms-sn-nattbygg1-klient-fifty-cm-mms-endpoints.apps.stas-test.statnett.no/larm/statnett-fifty-intern-client-jar-with-dependencies.jar'
.

I wonder what is it in you jar file that is making OWS process it after invoking main? What are the contents of your jar i.e. the directory structure within the jar and contents of JNLP-INF and META-INF folder and manifest? I would like to see the structure of your Jar because OWS is finding an element in the Jar file which is making it read the jar file and processing the APPLICATION_TEMPLATE again and again.
Attachments
Sample.zip
(970 Bytes) Downloaded 17 times

magnusska
Posts: 16
Joined: 24 Feb 2023, 16:11

Re: Application not launching - looks like looping behavior

Post by magnusska »

Still looking for the problem.
I put some System.out statements in the startup and it does not complete.

Code: Select all

[ITW-CORE][2023-03-28 14:40:17.773 CEST][DEBUG][net.sourceforge.jnlp.runtime.CachedJarFileCallback] Class-Path attribute cleared for C:\Users\magnusska\.cache\icedtea-web\cache\0\19\statnett-fifty-intern-client-jar-with-dependencies.jar
[ITW-APP ][2023-03-28 14:40:17.967 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] ArbeidsflateStarter startMedArgs
[ITW-APP ][2023-03-28 14:40:17.975 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] ArbeidsflateStarter setApplikasjonsNavn
[ITW-APP ][2023-03-28 14:40:17.975 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] ArbeidsflateStarter commandLineArgs
[ITW-APP ][2023-03-28 14:40:17.978 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] ArbeidsflateStarter lesLarmCommandLine parser
[ITW-APP ][2023-03-28 14:40:17.979 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] ArbeidsflateStarter lesLarmCommandLine options
[ITW-APP ][2023-03-28 14:40:17.986 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] ArbeidsflateStarter lesLarmCommandLine try
[ITW-APP ][2023-03-28 14:40:17.988 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] ArbeidsflateLookAndFeel settStandardLookAndFeel
[ITW-APP ][2023-03-28 14:40:18.053 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] ArbeidsflateLookAndFeel settStandardLookAndFeel done
[ITW-APP ][2023-03-28 14:40:18.053 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] Arbeidsflate setDefaultTekniskFeilmelding
[ITW-APP ][2023-03-28 14:40:18.055 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] ArbeidsflateStarter serverUrl: https://mms-sn-nattbygg1-klient-fifty-cm-mms-endpoints.apps.stas-test.statnett.no/larm
[ITW-APP ][2023-03-28 14:40:18.056 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] ArbeidsflateStarter proxy
[ITW-APP ][2023-03-28 14:40:18.056 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] ArbeidsflateStarter auth: false
[ITW-APP ][2023-03-28 14:40:18.058 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] DigestProxy ctor
[ITW-APP ][2023-03-28 14:40:18.059 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] DigestProxy url: https://mms-sn-nattbygg1-klient-fifty-cm-mms-endpoints.apps.stas-test.statnett.no/larm/service/larmServer
[ITW-APP ][2023-03-28 14:40:18.070 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] DigestProxy ClientBuilder
[ITW-APP ][2023-03-28 14:40:18.073 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] HttpClient build
[ITW-APP ][2023-03-28 14:40:18.074 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] HttpClient build null
[ITW-APP ][2023-03-28 14:40:18.074 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] getDefaultRequestConfig
[ITW-APP ][2023-03-28 14:40:18.074 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] HttpClient build clientBuilder
[ITW-APP ][2023-03-28 14:40:18.154 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] HttpClient done
[ITW-APP ][2023-03-28 14:40:18.154 CEST][INFO ][java.base/sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:233)] DigestProxy ClientExecutor
[ITW-CORE][2023-03-28 14:40:18.159 CEST][DEBUG][net.adoptopenjdk.icedteaweb.resources.ResourceTracker] Create resource for 'https://mms-sn-nattbygg1-klient-fifty-cm-mms-endpoints.apps.stas-test.statnett.no/larm/statnett-fifty-intern-client-jar-with-dependencies.jar'
From codebase:

Code: Select all

        System.out.println("DigestProxy ClientBuilder: " + clientHttpClientBuilder.getDefaultRequestConfig());
        System.out.println("DigestProxy ClientExecutor");
        ClientHttpRequestExecutor httpExecutor = new ClientHttpRequestExecutor(httpClient, clientHttpClientBuilder.getDefaultRequestConfig());
        System.out.println("DigestProxy ClientExecutor done");
new ClientHttpRequestExecutor(... -> this also has output, looks like it is never called

Code: Select all

    
    ClientHttpRequestExecutor(HttpClient httpClient, RequestConfig defaultRequestConfig) {
        System.out.println("ClientExecutor ctor");
        this.httpClient = httpClient;
        this.defaultRequestConfig = defaultRequestConfig;
    }

magnusska
Posts: 16
Joined: 24 Feb 2023, 16:11

Re: Application not launching - looks like looping behavior

Post by magnusska »

What I find really odd is that this occurs 2 times, 2nd time after app is launched;
[DEBUG][net.adoptopenjdk.icedteaweb.resources.ResourceTracker] Create resource for 'https://mms-sn-nattbygg1-klient-fifty-c ... encies.jar'

The app is clearly starting, it just doesn't complete startup.

Janak Mulani
Posts: 564
Joined: 24 Mar 2020, 13:37

Re: Application not launching - looks like looping behavior

Post by Janak Mulani »

would you consider buying paid support or online consulting? Then I can have a deeper look at your app.

OWS is starting your app, but OWS is also finding something in your jar which is making it read the APPLICATION_TEMPLATE.JNLP again and again.

What is the content of your jar file?

magnusska
Posts: 16
Joined: 24 Feb 2023, 16:11

Re: Application not launching - looks like looping behavior

Post by magnusska »

Paid support is above my paygrade unfortunately.

Like I said before, this runs smoothly on javaws 1.8. I was under the impression that migrating to OWS would be simple...

The jar file contains everything needed to run the app.
Contents of META_INF look like attachment.
Attachments
meta_inf.jpg
meta_inf.jpg (147.74 KiB) Viewed 886 times

Janak Mulani
Posts: 564
Joined: 24 Mar 2020, 13:37

Re: Application not launching - looks like looping behavior

Post by Janak Mulani »

This is just the META-INF. What about the other content at root level?

What does your INDEX.LIST contain?

magnusska
Posts: 16
Joined: 24 Feb 2023, 16:11

Re: Application not launching - looks like looping behavior

Post by magnusska »

Start of INDEX.LIST:

Code: Select all

JarIndex-Version: 1.0

statnett-fifty-intern-client-jar-with-dependencies.jar

JNLP-INF
_351
_351/iec62325
_351/iec62325/tc57wg16
_351/iec62325/tc57wg16/_451_3
_351/iec62325/tc57wg16/_451_3/capacityspecificationdocument
_351/iec62325/tc57wg16/_451_3/capacityspecificationdocument/_7
_351/iec62325/tc57wg16/_451_3/capacityspecificationdocument/_7/_1
_351/iec62325/tc57wg16/_451_3/implicitauctiondocument
_351/iec62325/tc57wg16/_451_3/implicitauctiondocument/_7
_351/iec62325/tc57wg16/_451_3/implicitauctiondocument/_7/_0
_351/iec62325/tc57wg16/_451_3/totalallocationresultdocument
_351/iec62325/tc57wg16/_451_3/totalallocationresultdocument/_7
_351/iec62325/tc57wg16/_451_3/totalallocationresultdocument/_7/_0
_351/iec62325/tc57wg16/_451_5
_351/iec62325/tc57wg16/_451_5/statusrequestdocument
_351/iec62325/tc57wg16/_451_5/statusrequestdocument/_4
_351/iec62325/tc57wg16/_451_5/statusrequestdocument/_4/_0
_351/iec62325/tc57wg16/_451_6
_351/iec62325/tc57wg16/_451_6/configurationdocument
_351/iec62325/tc57wg16/_451_6/configurationdocument/_3
_351/iec62325/tc57wg16/_451_6/configurationdocument/_3/_0
_351/iec62325/tc57wg16/_451_6/outagedocument
_351/iec62325/tc57wg16/_451_6/outagedocument/_3
_351/iec62325/tc57wg16/_451_6/outagedocument/_3/_0
_351/iec62325/tc57wg16/_451_6/transmissionnetworkdocument
_351/iec62325/tc57wg16/_451_6/transmissionnetworkdocument/_4
_351/iec62325/tc57wg16/_451_6/transmissionnetworkdocument/_4/_0
about_files
ca
ca/odell
ca/odell/glazedlists
ca/odell/glazedlists/calculation
... list of packages ...

Code: Select all

xsd/schemas/Documents
LICENSE.md
LarmMessages_no_NO.properties
LarmMessages_sv_SE.properties
PropertyList-1.0.dtd
attribute.rng
bindings.xjb
complexType.rng
digesterRules.xml
element.rng
include.rng
jaxws-databinding-translate-namespaces.xml
jaxws-databinding.xsd
larm-print-prodplan.css
larm-print-regulering.css
larm-print.css
logback-client.xml
logback-console.xml
modelGroup.rng
module-info.class
plugin.properties
properties.dtd
release-documentation.pdf
simpleType.rng
sun-jaxws.xsd
task-dialog.properties
task-dialog_de_DE.properties
task-dialog_es_ES.properties
task-dialog_fr_FR.properties
task-dialog_it_IT.properties
task-dialog_pl_PL.properties
task-dialog_pt_BR.properties
task-dialog_pt_PT.properties
task-dialog_zh_CN.properties
xml-pic.jpg
xmlschema.rng

magnusska
Posts: 16
Joined: 24 Feb 2023, 16:11

Re: Application not launching - looks like looping behavior

Post by magnusska »

JNLP-INF contains only APPLICATION_TEMPLATE.JNLP
Contents of jar (root)
jar-with-dependencies.jpg
jar-with-dependencies.jpg (312.87 KiB) Viewed 872 times

Janak Mulani
Posts: 564
Joined: 24 Mar 2020, 13:37

Re: Application not launching - looks like looping behavior

Post by Janak Mulani »

I created a sample jar with JNLP-INF containing APPLICATION_TEMPLATE.JNLP and also INDEX.LIST:

Code: Select all

75 Fri Mar 31 17:17:34 IST 2023 META-INF/INDEX.LIST
     0 Fri Mar 31 17:17:06 IST 2023 META-INF/
    58 Fri Mar 31 17:17:06 IST 2023 META-INF/MANIFEST.MF
  1882 Wed Mar 09 13:12:36 IST 2022 Hello.class
   699 Wed Mar 09 13:12:34 IST 2022 Hello.java
     0 Thu Mar 30 18:24:00 IST 2023 JNLP-INF/
   659 Sat Mar 25 18:16:56 IST 2023 JNLP-INF/APPLICATION_TEMPLATE.JNLP
INDEX.LIST

Code: Select all

JarIndex-Version: 1.0

signed-jnlp-11.jar
Hello.class
Hello.java
JNLP-INF
OWS is reading only one APPLICATION_TEMPLATE.JNLP:

Code: Select all

[ITW-CORE][2023-03-31 17:23:42.581 IST][DEBUG][net.sourceforge.jnlp.runtime.classloader.JNLPClassLoader] APPLICATION_TEMPLATE.JNLP has been located within signed JAR. Starting verification...
Can you unjar or jar tvf your jar and check if there is an APPLICATION_TEMPLATE.JNLP other than in JNLP-INF?

Can you try removing JNLP-INF from INDEX.LIST and see what happens?

Post Reply