libjli.so is needed by OpenwebStart

The place to exchange and discuss feature requests and proposals. Please post specific bug reports, pull requests, or source code extensions on github.
Ashok
Posts: 18
Joined: 01 Dec 2021, 08:40

libjli.so is needed by OpenwebStart

Post by Ashok »

Hi,
Initially, in the new RHEL 8.4 OS platform, I have installed amazon corretto 8 JDK. Later, I tried to install the openwebstart 1.5.0 in RHEL 8.4 OS platform. But the installation got failed with the below error,
error: Failed dependencies:
libjli.so()(64bit) is needed by openwebstart-1.5.0-2.x86_64
libjli.so(SUNWprivate_1.1)(64bit) is needed by openwebstart-1.5.0-2.x86_64

And I can able to locate the libjli.so under JDK path. But still, I got the above error.

Please let me know the workaround solution.

Thanks.

Janak Mulani
Posts: 495
Joined: 24 Mar 2020, 13:37

Re: libjli.so is needed by OpenwebStart

Post by Janak Mulani »

Which installer did you take?

For Linux you have to use this installer:
https://github.com/karakun/OpenWebStart ... _1_5_0.deb

openwebstart-1.5.0-2.x86_64 this is a windows installer.

Ashok
Posts: 18
Joined: 01 Dec 2021, 08:40

Re: libjli.so is needed by OpenwebStart

Post by Ashok »

Hi,

I have converted the ".deb" to ".rpm" format and tried to install it.

Also please let me know whether I can download openwebstart in ".rpm" format directly from any website.

Thanks,

Janak Mulani
Posts: 495
Joined: 24 Mar 2020, 13:37

Re: libjli.so is needed by OpenwebStart

Post by Janak Mulani »

We do not provide .rpm..

This link https://github.com/karakun/OpenWebStart/issues/154 shows how to convert .deb to .pm which you said you have already done.

I hope you installation was successful.

Ashok
Posts: 18
Joined: 01 Dec 2021, 08:40

Re: libjli.so is needed by OpenwebStart

Post by Ashok »

I have converted the ".deb" into ".rpm" without any errors and while installing the same was throwing the above-mentioned error.

Please let me know the possibilities to install the openwebstart rpm file without errors.

Stephan Classen
Posts: 224
Joined: 27 Mar 2020, 09:55

Re: libjli.so is needed by OpenwebStart

Post by Stephan Classen »

Sorry we do not have the resources to support more than .deb at the moment.
Non of the devs is currently using a rpm based package manager.

If you find a solution to your problem we are very great full if you can post it here so that others with the same issue can find a solution.

Ashok
Posts: 18
Joined: 01 Dec 2021, 08:40

Re: libjli.so is needed by OpenwebStart

Post by Ashok »

Kindly please let me know whether OpenwebStart 1.5.0 is compatible with RHEL 8.4 or not.

Thanks,

Janak Mulani
Posts: 495
Joined: 24 Mar 2020, 13:37

Re: libjli.so is needed by OpenwebStart

Post by Janak Mulani »

We have not tested on RHEL but it should work.

Ashok
Posts: 18
Joined: 01 Dec 2021, 08:40

Re: libjli.so is needed by OpenwebStart

Post by Ashok »

I tried to install the rpm package without checking dependencies by using the below command,
rpm -i --nodeps openwebstart-1.5.0-2.x86_64.rpm
The installation was successful. But have a doubt that whether it will have any impact or not. Also, I tried to launch the .jnlp file by using openwebstart and it works fine.

Please let me know how can we check whether the above installation was a precise process or not.

Thanks,

Stephan Classen
Posts: 224
Joined: 27 Mar 2020, 09:55

Re: libjli.so is needed by OpenwebStart

Post by Stephan Classen »

If a JNLP can be launched then it works.

The installer manly does the following steps:
- copy all files to the disk (for linux this is /opt/OpenWebStart)
- register OWS as an executable for *.jnlp and *.jnlpx files
- register an icon for *.jnlp and *.jnlpx files

The second and third steps are not required for OWS to function. They mainly add usability for the UI

Post Reply