Open with specific Java version

The public knowledge pool and discussion forum of the OWS community. Do not post confidential information here!
armin
Posts: 3
Joined: 24 Feb 2022, 15:18

Open with specific Java version

Post by armin »

Hello there,

I have multiple jnlp-files that I want to open using OWS.
Unfortunately, they are in different Java-versions.

I have added my own default server to download the JVMs and added the different paths to the JSON-file.
If I write "

Code: Select all

<j2se version="1.11+"/>
" it downloads the latest one of course, in my case the 1.13.
If I only write "

Code: Select all

<j2se version="1.11"/>
" it says that it couldn't find a JVM.
While reading through the log to find out what it is doing, I read the following:
"Trying to find remote Java runtime. Requested version: '1.11*' Requested vendor: '*' requested os: 'WIN64'"
Afterwards it is looking through my json to find a fitting jvm but doesn't find any.

Does anyone know what I should do to be able to run my application on the exact JVM I want to and not the newest one?

Thank you in advance.

armin
Last edited by armin on 19 Sep 2022, 13:21, edited 2 times in total.

Janak Mulani
Posts: 500
Joined: 24 Mar 2020, 13:37

Re: Open with specific Java version

Post by Janak Mulani »

Hi

Why are you specifying j2se version as "1.x"? Why not 11 or 11* or 11+?

armin
Posts: 3
Joined: 24 Feb 2022, 15:18

Re: Open with specific Java version

Post by armin »

Hi Janak,

thank you for your fast response.

I wrote it like that because I saw it in an example.
I just tried it the way you wrote it and it worked, I really appreciate it.

Have a nice day and thanks again.

armin

Post Reply