No suitable JVM was found to start the application

Get help with installation and configuration of OWS. Please post specific bug reports, pull requests, or source code extensions on github.
Posts: 1
Joined: 22 Jul 2020, 04:42

No suitable JVM was found to start the application

Post by ChrisH »


I am trying to get OpenWebStart to work with a JNLP file from Daimler.

However I am getting the following 'No suitable JVM was found to start the application' when trying to open the JNLP.

I have tried the provided FAQ from them, which referenced to the Manager Configuration however still no change.

Using MacOS.

Any help would be greatly appreciated.

Andreas Ehret
Posts: 81
Joined: 25 Mar 2020, 12:21

Re: No suitable JVM was found to start the application

Post by Andreas Ehret »

It sounds like you do not have configured a suitable JVM in your OpenWebStart settings that matches to what your JNLP application requests.

The version and vendor settings in your jnlp file determine which JVMs are possible (e.g. <java version="1.8*"> or <j2se version="1.7+" vendor="Oracle"/>).
Depending on the configuration of properties in the OWS settings these attributes are honored or not (e.g. vendor).

Some OWS customers also provide its own JVM download server to define which JVMs should be possible to select. In the OWS settings JVM manager you see the which JVMs are activated to be used by your JNLP application.

Whether you are allowed to change this settings or not depends on your global setup and what is pre-configured by Daimler. In this case you need the help of Daimler aftersales.

See my private post to you for Daimler aftersales contacts and more details on how to proceed.

Janak Mulani
Posts: 817
Joined: 24 Mar 2020, 13:37

Re: No suitable JVM was found to start the application

Post by Janak Mulani »


In your jnlp you specify java version as :

Code: Select all

<j2se version="1.8.0_212_02257_36064" href="https://***/JVM/jvms.json"/>
This means that you are expecting this specific version to be downloaded from the JVM server specified in the "href" if not already present locally.

Can you please do the following:

1. Try specifying j2se version = 1.8*

2. Check using itw-settings > JVM manager > settings whether "Allow Server From JNLP" is checked. I.e. downloading a jvm from the jvm server specified in jnlp file is allowed.

3. Ask the provider of this jnlp file why this specific version of jvm has been specified in the jnlp file and whether that specific version is available on the JVM server specified in the href.. In fact you can yourself check by typing the jvm server href url in browser and checking if the json has an entry for the specified jvm.



Stephan Classen
Posts: 232
Joined: 27 Mar 2020, 09:55

Re: No suitable JVM was found to start the application

Post by Stephan Classen »

Also could you provide the logs from the failed application start.
It contains more details what OpenWebStart tried to find a suitable JVM

Post Reply